Describes the cause of the element notification.
typedef enum { APINotifyElement_BeginEvents = -1, APINotifyElement_EndEvents = -2, APINotifyElement_New = 1, APINotifyElement_Copy = 2, APINotifyElement_Change = 3, APINotifyElement_Edit = 4, APINotifyElement_Delete = 5, APINotifyElement_Undo_Created = 11, APINotifyElement_Undo_Modified = 12, APINotifyElement_Undo_Deleted = 13, APINotifyElement_Redo_Created = 14, APINotifyElement_Redo_Modified = 15, APINotifyElement_Redo_Deleted = 16, APINotifyElement_PropertyValueChange = 17, APINotifyElement_ClassificationChange = 18 } API_ElementDBEventID;
Members
- APINotifyElement_BeginEvents
- Indicates the start of element notifications.
- APINotifyElement_EndEvents
- End of element notifications (no more notifications are expected in this task).
- APINotifyElement_New
- A new element was created.
- APINotifyElement_Copy
- The element was copied; the notifications are coming for the copy of the original element.
- APINotifyElement_Change
- The parameters of the element were changed.
- APINotifyElement_Edit
- The element was edited. The parameters of the editing transformation can be retrieved with ACAPI_Notify_GetTranParams.
- APINotifyElement_Delete
- The element was deleted.
- APINotifyElement_Undo_Created
- The last creating operation performed on the element has been undone.
- APINotifyElement_Undo_Modified
- The last modifying operation performed on the element has been undone.
- APINotifyElement_Undo_Deleted
- The last deleting operation performed on the element has been undone.
- APINotifyElement_Redo_Created
- The last undone creating operation on the element has been redone.
- APINotifyElement_Redo_Modified
- The last undone modifying operation on the element has been redone.
- APINotifyElement_Redo_Deleted
- The last undone deleting operation on the element has been redone.
- APINotifyElement_PropertyValueChange
- A property value attached to the element has been changed.
- APINotifyElement_ClassificationChange
- An element’s classification has changed.
Remarks
This enumeration type is used in the API_NotifyElementType structure.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Callback.h
See Also
API_NotifyElementType
APIElementEventHandlerProc
ACAPI_Notify_CatchNewElement
ACAPI_Element_AttachObserver
ACAPI_Notify_GetTranParams
API Types