API_​ElementMemo

Describes the variable length additional data of elements.

    typedef struct {
        API_Coord                        **coords;
        Int32                            **pends;
        API_PolyArc                      **parcs;
        UInt32                           **vertexIDs;
        UInt32                           **edgeIDs;
        UInt32                           **contourIDs;
        API_AddParType                   **params;
        API_Gable                        **gables;
        API_EdgeTrim                     **edgeTrims;
        double                           **meshPolyZ;
        API_MeshLevelCoord               **meshLevelCoords;
        Int32                            **meshLevelEnds;
        API_DimElem                      **dimElems;
        API_SplineDir                    **bezierDirs;
        char                             **textContent;
        short                            **textLineStarts;
        API_Beam_Hole                    **beamHoles;
        API_LinkType                     **linkList;
        char                             **pictHdl;
        API_ParagraphType                **paragraphs;
        GSPtr                            drawingData;
        ProfileVectorImage               *customOrigProfile;
        ProfileVectorImage               *stretchedProfile;
        GSPtr                            customParams;
        API_SectionSegment               *intElevSegments;
        API_Coord                        *sectionSegmentMainCoords;
        API_Coord                        *sectionSegmentDistCoords;
        API_Coord                        *sectionSegmentDepthCoords;
        API_Guid                         *wallWindows;
        API_Guid                         *wallDoors;
        API_GridMesh                     *cWSegGridMesh;
        API_CWContourData                *cWSegContour;
        API_CWSegmentPatternData         cWSegPrimaryPattern;
        API_CWSegmentPatternData         cWSegSecondaryPattern;
        API_CWSegmentPatternCellData     *cWSegPatternCells;
        API_CWSegmentType                *cWallSegments;
        API_CWFrameType                  *cWallFrames;
        API_CWFrameType                  *cWallFrameDefaults;
        API_Guid                         *cWallFrameDefaultSymbs;
        API_CWPanelType                  *cWallPanels;
        API_CWPanelGridIDTable           *cWallPanelGridIDTable;
        API_CWPanelType                  *cWallPanelDefaults;
        API_Guid                         *cWallPanelDefaultSymbs;
        API_CWJunctionType               *cWallJunctions;
        API_CWAccessoryType              *cWallAccessories;
        API_StairRiserType               *stairRisers;
        API_StairTreadType               *stairTreads;
        API_StairStructureType           *stairStructures;
        API_StairBoundaryData            stairBoundary[2];
        API_StairPolylineData            stairBaseLine;
        API_StairPolylineData            stairWalkingLine;
        API_RailingNodeType              *railingNodes;
        API_RailingSegmentType           *railingSegments;
        API_RailingPostType              *railingPosts;
        API_RailingRailEndType           *railingRailEnds;
        API_RailingRailConnectionType    *railingRailConnections;
        API_RailingRailEndType           *railingHandrailEnds;
        API_RailingRailConnectionType    *railingHandrailConnections;
        API_RailingRailEndType           *railingToprailEnds;
        API_RailingRailConnectionType    *railingToprailConnections;
        API_RailingRailType              *railingRails;
        API_RailingToprailType           *railingToprails;
        API_RailingHandrailType          *railingHandrails;
        API_RailingPatternType           *railingPatterns;
        API_RailingInnerPostType         *railingInnerPosts;
        API_RailingPanelType             *railingPanels;
        API_RailingBalusterSetType       *railingBalusterSets;
        API_RailingBalusterType          *railingBalusters;
        double                           **polyZCoords;
        API_RoofEdgeTypeID               *roofEdgeTypes;
        API_OverriddenAttribute          *sideMaterials;
        API_Coord                        **additionalPolyCoords;
        Int32                            **additionalPolyPends;
        API_PolyArc                      **additionalPolyParcs;
        UInt32                           **additionalPolyVertexIDs;
        UInt32                           **additionalPolyEdgeIDs;
        UInt32                           **additionalPolyContourIDs;
        API_PivotPolyEdgeData            *pivotPolyEdges;
        API_ShellShapeData               shellShapes[2];
        API_ShellContourData             *shellContours;
        Modeler::Body                    *morphBody;
        API_OverriddenAttribute          *morphMaterialMapTable;
        GS::UniString                    *elemInfoString;
        API_BeamSegmentType              *beamSegments;
        API_ColumnSegmentType            *columnSegments;
        API_AssemblySegmentCutData       *assemblySegmentCuts;
        API_AssemblySegmentSchemeData    *assemblySegmentSchemes;
        API_AssemblySegmentProfileData   *assemblySegmentProfiles;
        API_SurfaceLoadCustomData   		*surfaceLoadCustomData;
    } API_ElementMemo;

 

Members

coords
Coordinate array (used for polygons, spline coordinates, etc.).
pends
Polygon endpoints; see API_Polygon for more information.
parcs
Polygon arcs; see API_PolyArc and API_Polygon for more information.
vertexIDs
Unique identifiers the polygon vertices (unique inside the polygon).
edgeIDs
Unique identifiers the polygon edges (unique inside the polygon).
contourIDs
Unique identifiers the polygon contours (unique inside the polygon).
params
Additional parameters for library part-based elements.
gables
Parameters of the cutting planes the element has been cut with.
edgeTrims Featuring API 15
Trim data of slab/roof/shell edges. (Formerly roofSides.)
meshPolyZ
Z coordinates of mesh polygon points.
meshLevelCoords
Mesh level line coordinates.
meshLevelEnds
Mesh level line endpoints.
dimElems
Dimension elements.
bezierDirs
Bezier-spline directions.
textContent
Text content for textual elements.
textLineStarts
Text line starts array (indices into the text content).
beamHoles
Beam hole information.
linkList
Camera link list.
pictHdl
Picture content.
paragraphs 6.1
Paragraph informations for text and label element.
drawingData Featuring API 10
Internal format drawing data of an API_DrawingType element.
customOrigProfile Featuring API 10
The original custom profile data applied to the wall, beam, or column element, in HGX::VectorImage format (see API_ProfileAttrType).
stretchedProfile Featuring API 10
The stretched profile actually used by the wall, beam, or column element, in HGX::VectorImage format (see API_ProfileAttrType).
customParams Featuring API 10
Reserved for internal use.
intElevSegments 21
Segments of an interior elevation.
sectionSegmentMainCoords 21
Coordinates of the section/elevation/interior elevation main line.
sectionSegmentDistCoords 21
Coordinates of the section/elevation/interior elevation marked distant area line.
sectionSegmentDepthCoords 21
Coordinates of the section/elevation/interior elevation depth line.
wallWindows Changed in API 12
Guid list of Window elements in the specified Wall (output only).
Featuring API 15  For getting this information more effectively, you had better use the ACAPI_Element_GetConnectedElements function.
wallDoors Changed in API 12
Guid list of Door elements in the specified Wall (output only).
Featuring API 15  For getting this information more effectively, you had better use the ACAPI_Element_GetConnectedElements function.
cWSegGridMesh Added in API 12
Curtain wall segment grid mesh.
cWSegContour Added in API 12
The contour of Curtain Wall segments.
cWSegPrimaryPattern Changed in API 22
Curtain Wall primary segment pattern.
cWSegSecondaryPattern Changed in API 22
Curtain Wall secondary segment pattern.
cWSegPatternCells Added in API 22
Curtain Wall segment pattern cells.
cWallSegments Added in API 12
Curtain Wall segments.
cWallFrames Added in API 12
Curtain Wall frame instances.
cWallFrameDefaults Added in API 22
Curtain Wall custom frame defaults (categories/classes).
cWallFrameDefaultSymbs Added in API 22
Curtain Wall frame default (category/class) symbols.
cWallPanels Added in API 12
Curtain Wall panel instances.
cWallPanelGridIDTable Added in API 22
This table contains the grid mesh identifiers for each Curtain Wall panel instance (these grid mesh cells are partly or fully covered by the panel).
typedef GS::HashTable<API_Guid, GS::Array<API_GridElemID>> API_CWPanelGridIDTable;
cWallPanelDefaults Added in API 22
Curtain Wall panel defaults (categories/classes).
cWallPanelDefaultSymbs Added in API 22
Curtain Wall panel default (category/class) symbols.
cWallJunctions Added in API 12
Curtain Wall junction instances.
cWallAccessories Added in API 12
Curtain Wall accessory instances.
stairRisers Changed in API 21
Stair Riser subelements.
stairTreads Changed in API 21
Stair Tread subelements.
stairStructures Changed in API 21
Stair Structure subelements.
stairBoundary Changed in API 21
Stair boundaries (index 0 is the left, and 1 is the right).
stairBaseLine Changed in API 21
The base line of a Stair element.
stairWalkingLine Changed in API 21
The walking line of a Stair element.
stairCustomWalkLine Changed in API 21
The customized walking line of a Stair element.
stairCenterWalkLine Changed in API 21
The default, centered walking line of a Stair element.
railingNodes Changed in API 21
Railing Node subelements.
railingSegments Changed in API 21
Railing Segment subelements.
railingPosts Changed in API 21
Railing Post subelements.
railingRailEnds Changed in API 21
Rail End subelements.
railingRailConnections Changed in API 21
Rail Connection subelements.
railingHandrailEnds Changed in API 21
Handrail End subelements. Only filled for Railing elements. If a Railing Node element is queried, these can be found inside the Element’s structure.
railingHandrailConnections Changed in API 21
Handrail Connection subelements. Only filled for Railing elements. If a Railing Node element is queried, these can be found inside the Element’s structure.
railingToprailEnds Changed in API 21
Toprail End subelements. Only filled for Railing elements. If a Railing Node element is queried, these can be found inside the Element’s structure.
railingToprailConnections Changed in API 21
Toprail Connection subelements. Only filled for Railing elements. If a Railing Node element is queried, these can be found inside the Element’s structure.
railingRails Changed in API 21
Rail subelements.
railingToprails Changed in API 21
Toprail subelements.
railingHandrails Changed in API 21
Handrail subelements.
railingPatterns Changed in API 21
Railing Pattern subelements.
railingInnerPosts Changed in API 21
Inner Post subelements.
railingBalusterSets Changed in API 21
Baluster Set subelements.
railingBalusters Changed in API 21
Baluster subelements.
polyZCoords Changed in API 21
Array for the Z coordinates of a coordinate array.
roofEdgeTypes Changed in API 13
Roof edge types.
sideMaterials Changed in API 20
Roof / Slab side materials.
additionalPolyCoords Featuring API 15
Coordinate array of the pivot polygon of a Multi-plane Roof element (see API_PolyRoofData) or the found polygon of the zone element. In case of zones, it can be nullptr if zone does not have found polygon. Also this is output only parameter for zones. Can be accessed with the APIMemoMask_AdditionalPolygon memo mask.
additionalPolyPends Featuring API 15
Polygon endpoints of the pivot polygon of a Multi-plane Roof element (see API_PolyRoofData) or the found polygon of the zone element. Can be accessed with the APIMemoMask_AdditionalPolygon memo mask. See also API_Polygon for more information.
additionalPolyParcs Featuring API 15
Polygon arcs of the pivot polygon of a Multi-plane Roof element (see API_PolyRoofData) or the found polygon of the zone element. Can be accessed with the APIMemoMask_AdditionalPolygon memo mask. See also API_PolyArc and API_Polygon for more information.
additionalPolyVertexIDs Featuring API 15
Unique identifiers the polygon vertices of the pivot polygon of a Multi-plane Roof element (see API_PolyRoofData). Not used for zones. Can be accessed with the APIMemoMask_AdditionalPolygon memo mask.
additionalPolyEdgeIDs Featuring API 15
Unique identifiers the polygon edges of the pivot polygon of a Multi-plane Roof element (see API_PolyRoofData). Not used for zones. Can be accessed with the APIMemoMask_AdditionalPolygon memo mask.
additionalPolyContourIDs Featuring API 15
Unique identifiers the polygon contours of the pivot polygon of a Multi-plane Roof element (see API_PolyRoofData). Not used for zones. Can be accessed with the APIMemoMask_AdditionalPolygon memo mask.
pivotPolyEdges Featuring API 15
Multi-plane roof specific data associated to the edges of the pivot polygon. They contain geometry (angle, eavesOverHang) and attribute (material etc.) data for each segment (see API_PivotPolyEdgeData). Can be accessed with the APIMemoMask_PivotPolygon memo mask.
shellShapes Featuring API 15
Shell specific data to describe the profiles that form the shell shape. Extruded and revolved shells use the first (0-indexed) record only, ruled shells use both. This is a required parameter to pass when creating a new shell element.
shellContours Featuring API 15
Shell specific data to define body contour and hole contours to the shell element. If hasContour is true, the first record contains the body contour data. If the shell has holes (numHoles > 0), the following items of the array describe the hole contours (the first hole contour is located in the second (1-indexed) record if there is a body contour given, otherwise it is in the first (0-indexed) record).
morphBody Featuring API 16
Morph element.
morphMaterialMapTable Changed in API 20
Morph element.
elemInfoString Featuring API 19
Info string of the element.
beamSegments Featuring API 23
Beam segments.
columnSegments Featuring API 23
Column segments.
assemblySegmentCuts Featuring API 23
Cuts of segments.
assemblySegmentSchemes Featuring API 23
Segment schemes.
assemblySegmentProfiles Featuring API 23
Segment profiles.
surfaceLoadCustomData Featuring API 25
Custom Surface Load contour data.

 

Remarks

See ACAPI_Element_GetMemo to find out which element type needs/provides which information in the memo.

If you retrieve an array of vertices, edges or contours with ACAPI_Element_GetMemo, do not change the IDs in these arrays. New vertices, edges and contours should be inserted with ID = 0.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetMemo
API_Coord, API_PolyArc, API_AddParType, API_Gable, API_EdgeTrim
API_MeshLevelCoord, API_DimElem, API_SplineDir
API_Beam_Hole, API_LinkType, API_ParagraphType
API_Polygon, API_DrawingType, API_ProfileAttrType, API_SectionSegment,
API_CWContourData, API_CWSegmentType, API_CWJunctionType, API_CWAccessoryType, API_CWPanelType, API_CWFrameType,
API_RoofEdgeTypeID, API_PivotPolyEdgeData, API_ShellShapeData API_ShellContourData, API_OverriddenAttribute, API_StairRiserType, API_StairTreadType, API_StairStructureType
API_BeamSegmentType, API_ColumnSegmentType, API_AssemblySegmentData API_AssemblySegmentSchemeData, API_AssemblySegmentProfileData
Element Manager, API Types