Selected elements for IFC export.
typedef enum { API_EntireProject = 1, API_VisibleElementsOnAllStories, API_AllElementsOnCurrentStorey, API_VisibleElementsOnCurrentStorey, API_SelectedElementsOnly, API_FilteredElements } API_ElementsToIfcExportID;
Members
- API_EntireProject
- All elements in the current project.
- API_VisibleElementsOnAllStories
- Visible elements on all stories
- API_AllElementsOnCurrentStorey
- All elements on current storey
- API_VisibleElementsOnCurrentStorey
- Visible elements on current storey
- API_SelectedElementsOnly
- Selected elements only
- API_FilteredElements
- Filtered elements
Remarks
This type specifies in API_SavePars_Ifc.
Requirements
- Version: API 23 or later
- Header: APIdefs_Automate.h