API_​ElementUserData

User data record to assign to an element.

    typedef struct {
      short              dataVersion;
      unsigned short     platformSign;
      GSFlags            flags;
      Int32              filler_1;
      GSHandle           dataHdl;
    } API_ElementUserData;

 

Members

dataVersion
the version of the user data
platformSign
the platform the data was created on; defines the byte ordering (can be either GS::Win_Platform_Sign, GS::Mac_Platform_Sign or GS::Mactel_Platform_Sign 10)
flags
specifies the behavior of the user data in certain operations (see Remarks)
dataHdl
the actual user data (arbitrary size)

 

Remarks

Detailed description given in Save data into Element records section.

Use the ACAPI_Element_SetUserData and ACAPI_Element_GetUserData functions to operate on this data.

The possible values of flags are:

APIUserDataFlag_Copy Copy the user data into the copied element also
APIUserDataFlag_Merge Merge user data with the element
APIUserDataFlag_FillWith Inject user data into the element instance from element default
APIUserDataFlag_Pickup Copy user data into element default at parameter transfer
APIUserDataFlag_SkipRecalcAndDraw Changed in API 12 ACAPI_Element_SetUserData skips recalc and redraw (input only control flag)

From Archicad 20 all user data operations should be undoable.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_SetUserData, ACAPI_Element_GetUserData, API Types