3D data of an element.
typedef struct { UInt32 fElemIdx; UInt32 fBodyIdx; UInt32 lElemIdx; UInt32 lBodyIdx; Int32 fbody; Int32 lbody; Int32 flight; Int32 llight; Int32 filler_1[2]; API_Box3D bounds; } API_ElemInfo3D;
Members
- fElemIdx
- It is equal to the incoming element index.
- fBodyIdx
- It is always zero.
- lElemIdx
- It is equal to the incoming element index.
- lBodyIdx
- Index of the last body which belongs to the element. (not flat list)
- fbody
- Index of the first body which belongs to the element.
- lbody
- Index of the last body which belongs to the element.
- flight
- Index of the first light source which belongs to the element.
- llight
- Index of the last light source which belongs to the element.
- bounds
- The 3D bounding box of the element.
Remarks
Use the ACAPI_Element_Get3DInfo function to get the 3D representation of a construction element.
Once an element is converted to 3D, it will have the following components:
- model information based on BODYs,
- lighting model based on LIGHTs; if lights are defined from the 3D GDL script,
- materials; either from the global attribute pool, or defined from the 3D GDL script.
All of the data can be accessed through the API_Component3D structure.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h