API_​ElemPartSurfaceQuantity

Describes the different calculated values for surfaces of elements.

    typedef struct {
        API_Guid           elemGUID;
        API_AttributeIndex materialIndex;
        API_AttributeIndex buildMatIdx;
        double             exposedSurface;
    } API_ElemPartSurfaceQuantity;

 

Members

elemGUID
GUID of the element.
materialIndex
Index of the material, that the surface belongs to.
buildMatIdx
Building material index of the element, that the surface belongs to.
exposedSurface
Area of exposed surface

 

Requirements

Version: API 19 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, ACAPI_Element_GetSurfaceQuantities, ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API_ElementQuantity, API_QuantityPar, API Types