API_​ElemSearchPars

Structure to search an element by coordinate.

    typedef struct {
        API_ElemType            type;
        API_ElemFilterFlags     filterBits;
        API_Coord               loc;
        double                  z;
    } API_ElemSearchPars;

 

Members

type
element type to search
filterBits
the flags used for filtering (see ACAPI_Element_Filter)
loc
the location on 2D plan
z
level to search down from

 

Remarks

This structure is used to search an element by coordinate. Only polygonal elements are accepted.

The type of the element must be polygonal, and passed in the type field. Filters can be passed also to skip instances with based on certain attributes, such as visibility, floor number, layer reference and so on. Refer to the ACAPI_Element_Filter function for more details. The location to be search on should be passed in the loc field. The search algorithm will ignore all the elements being on higher level than specified in the z parameter.

The first element will be returned, that:

  • match to the element type
  • pass the filter
  • the coordinate is an internal point of the polygon
  • has the highest level below z

See the APIAny_SearchElementByCoordID function.

New in API 26 From version 26 the type of the typeID member was changed into API_ElemType.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_SearchElementByCoordID, ACAPI_Element_Filter, API_ElemTypeID, API_Coord, API Types