API_​ElemType

The type of an element.

    struct API_ElemType {
        API_ElemTypeID       typeID;
        API_ElemVariationID  variationID;
        API_Guid             classID;
    };

 

Members

typeID
The typeID of the element (see API_ElemTypeID).
variationID
Subcategory of the element (see API_ElemVariationID).
classID
The classID of the element. It is used when the typeID is API_ExternalElemType.

 

Remarks

Please note that assigning an API_ElemTypeID to API_ElemType sets the variationID to APIVarId_Generic.

 

Requirements

Version: API 26 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API Types