URL reference to be stored into elements.
typedef struct { char urlLink [512]; char description [256]; char filler [256]; } API_ElemURLRef;
Members
- urlLink
- The HTTP address of the URL (e.g. “http://www.graphisoft.com”)
- description
- Description text of the URL (e.g. “Graphisoft Home Page”)
Remarks
This structure is used for storing URL reference into Archicad database elements. The element URL data can be accessed with the APIDb_GetElementURLRefID and APIDb_SetElementURLRefID database functions.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Database.h