API_​ElemViewDepthLimitationsID

Depth limitation for the appearance of complex elements on the floor plan.

    typedef enum {
        API_ToFloorPlanRange,
        API_ToAbsoluteLimit,
        API_EntireElement
    } API_ElemViewDepthLimitationsID;

 

Members

API_ToFloorPlanRange
The element representation on the floor plan is limited by the floor plan cut plane range.
API_ToAbsoluteLimit
The element representation on the floor plan is limited by the floor plan cut plane’s absolute display limit.
API_EntireElement
Shows entire element, floor plan cut plane does not affect the floor plan representation.

 

Remarks

For a display option, view depth limitation defines how much of an element appears on the floor plan.

You can retrieve the current floor plan cut plane settings using the APIEnv_GetPreferencesID environment function with the API_FloorPlanCutDefinition structure.

 

Requirements

Version: API 10 or later
Header: APIdefs_Elements.h

 

See Also

API_BeamType, API_ColumnType, API_RoofType, API_WallType
API_FloorPlanCutDefinition
API Types