API_​EnvirParams

Describes the different parameters of the running environment.

    typedef struct {
        API_ServerApplicationInfo     serverInfo;
        API_AddOnInfo                 addOnInfo;
    } API_EnvirParams;

 

Members

serverInfo
Information about the server application the add-on is running under.
addOnInfo
Textual description of the add-on.

 

Remarks

This is the parameter of the CheckEnvironment function. The serverInfo member is read-only, while the addOnInfo part should be filled by the add-on by return.

From API 21 you shouldn’t call BNZeroMemory or memset on this structure.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Registration.h

 

See Also

CheckEnvironment
API_AddOnInfo
API_ServerApplicationInfo
API Types