API_​ESYMParams

Describes the current external symbol your add-on can work on.

    typedef struct {
        GSType            signature;
        short             method;
        short             filler_1;
        Int32             libInd;
        IO::Location      *location;
        API_AddParType    **params;
        Int32             filler_2[6];
    } API_ESYMParams;

 

Members

signature
A four-character identifier of your external symbol type. It’s is the same what you called ACAPI_Install_ESYMHandler with.
method
The type of the requested operation:

ESYM_NEW

Archicad opened a new external symbol for your add-on; the user chose your external symbol type from the New Library Part menu.

ESYM_EDIT

The user has begun editing one of your external symbols.

libInd
The library index of the symbol your add-on was called for.
location
The location of the external symbol your add-on was called for.
params Changed in API 12
Additional parameters of the external symbol.

 

Remarks

The is the parameter of the APIESYMCommandProc callback function, identifying the external symbol you should work on.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Callback.h

 

See Also

APIESYMCommandProc
API Types