API_​ExportIdMappingType

Describes the connection between the unsegmented surface member’s and the created segment’s edges and vertices.

    typedef struct {
        GS::HashTable<API_InternalAnalyticalMemberPartId, GS::Array<API_AnalyticalElemPartId>>           edges;
        GS::HashTable<API_InternalAnalyticalMemberPartId, GS::Array<API_AnalyticalElemPartId>>           vertices;
    } API_ExportIdMappingType;

 

Members

edges 24
The mapping between edges and the segment edges.
vertices 24
The mapping between vertices and the segment vertices.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types