API_​ExtrudedShellData

This structure holds the Extruded Shell specific data of API_ShellType.

    typedef struct {
        double                  slantAngle;
        double                  shapePlaneTilt;
        double                  begPlaneTilt;
        double                  endPlaneTilt;
        API_Polygon             shellShape;
        API_Coord3D             begC;
        API_Vector3D            extrusionVector;
        API_Vector              shapeDirection;
        API_ContourEdgeData     begShapeEdgeData;
        API_ContourEdgeData     endShapeEdgeData;
        API_ContourEdgeData     extrudedEdgeDatas[2];
    } API_ExtrudedShellData;

 

Members

slantAngle
Angle of the extrusion vector from the horizontal plane.
shapePlaneTilt
Parameter of the plane of the extruded profile.
begPlaneTilt
Parameter of the starting plane of the extrusion.
endPlaneTilt
Parameter of the end plane of the extrusion.
shellShape
Profile polygon specification to extrude. The shape data arrays are held in the first API_ShellShapeData record of shellShapes in API_ElementMemo.
begC
Start the extrusion from here (3D point).
extrusionVector
Extrude the profile in this direction (3D vector).
shapeDirection
Direction of the profile (2D vector).
begShapeEdgeData
Edge information for the starting plane of the shell
endShapeEdgeData
Edge information for the end plane of the shell
extrudedEdgeDatas
Edge information for the edges connecting points of the starting and end plane.

 

Remarks

For shell related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_ShellType, API_Polygon, API_ContourEdgeData
API_ShellShapeData, API_ElementMemo
Element Manager, API Types