API_​FileOpenPars

Parameters to open a new project file.

    typedef struct {
        API_FTypeID      fileTypeID;
        bool             libGiven;
        bool             useStoredLib;
        bool             enableSaveAlert;
        bool             filler_1;
        IO::Location     *file;
        IO::Location     *archiveLib;
    } API_FileOpenPars;

 

Members

fileTypeID
file format to open
libGiven
archiveLibSpec is passed or not
useStoredLib
try to load the libraries specified in the project file. If the stored pathes do not exist, the Library Manager dialog appears. In case of Archive project file the folder chooser dialog appears for selecting the appropriate library folder. This field is ignored if libGiven is true
enableSaveAlert
Show the “Save the current document before closing” alert, or automatically save it before closing.
file
specification of the target file
archiveLib
library folder to create if archive open (optional), nullptr otherwise

 

Remarks

For the utilization of this structure see the APIDo_OpenID automation function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Automate.h

 

See Also

APIDo_OpenID, API_FTypeID, API Types