API_​FileSavePars

Parameters to save the current project file.

    typedef struct {
        API_FTypeID      fileTypeID;
        Int32            filler_1;
        IO::Location     *file;
        Int32            filler_2[15];
    } API_FileSavePars;

 

Members

fileTypeID
output format
file
specification of the target file

 

Remarks

For the utilization of this structure see the APIDo_SaveID automation function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Automate.h

 

See Also

APIDo_SaveID, API_FTypeID,
API_SavePars_Archive, API_SavePars_Ifc, API_SavePars_Object, API_SavePars_Picture, API_SavePars_Plandump, API_SavePars_Pdf, API Types