API_​FillLine

Describes the details of a vectorial fill.

    typedef struct {
        double        lFreq;
        double        lDir;
        double        lOffsetLine;
        API_Coord     lOffset;
        short         filler_1;
        short         lPartNumb;
        Int32         lPartOffs;
    } API_FillLine;

 

Members

lFreq
The frequency of a fill line item, i.e. the distance between two ‘instances’ of this item.
lDir
The angle of a fill line item, measured CCW from the horizontal axis.
lOffsetLine
The parallel offset of a fill line item, measured from the (rotated) horizontal axis.
lOffset
The offset of a fill line item, given by its coordinates.
lPartNumb
The number of elements used for this fill line item in the fill_LineLenght array. It should always be even.
lPartOffs
The offset (start) if this fill line item in the fill_LineLenght array. It should always be even.

 

Remarks

Most of the items here correspond to the various parts of the Fill Types dialog in Archicad.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API_Coord, API_FilltypeType, API_AttributeDef,
API Types