API_​FillOrientationID

Determines the orientation of the fill pattern.

    typedef enum {
        APIFillOrientation_ProjectOrigin,
        APIFillOrientation_ElementOrigin,
        APIFillOrientation_FitToSkin
    } API_FillOrientationID;

 

Members

APIFillOrientation_ProjectOrigin
The fill pattern starts at the project origin.
APIFillOrientation_ElementOrigin
The fill pattern starts at the element origin.
APIFillOrientation_FitToSkin
The fill pattern is stretched inside the element.
(Typically used with composite skins, where the fill pattern is stretched to the skin thickness)

 

Requirements

Version: API 17 or later
Header: APIdefs_Attributes.h

 

See Also

API Types