API_​FloorPlanCutDefinition

Parameters of the Floor Plan Cut Plane Settings dialog.

    typedef struct {
        double     currCutLevel;
        double     topCutLevel;
        double     bottomCutLevel;
        short      topCutBaseStoryRelInd;
        short      bottomCutBaseStoryRelInd;
        Int32      filler;
        double     fixLevel2Absolute0;
    } API_FloorPlanCutDefinition;

 

Members

currCutLevel
The level of the cut plane that determines the appearance of elements on the floor plan of the current view
topCutLevel
Upper limit of the view range relative to the top story specified in topCutBaseStoryRelInd
bottomCutLevel
Lower limit of the view range relative to the bottom story specified in bottomCutBaseStoryRelInd
topCutBaseStoryRelInd
Elements of the floor plan will be displayed up to the given number of stories above the cut plane
bottomCutBaseStoryRelInd
Elements of the floor plan will be displayed down to the given number of stories below the cut plane
fixLevel2Absolute0
The absolute lowest display limit relative to the project zero where the elements of the floor plan are visible

 

Remarks

The Floor Plan Cut Plane Settings define the visibility limitations of floor plan elements on the current view. In their Floor Plan and Section settings the model elements can be set to be displayed on the floor plan according to the relative floor plan range or the absolute display limit (see API_ElemViewDepthLimitationsID).

In order to access to these global parameters use the APIEnv_GetPreferencesID environment function with the API_FloorPlanCutDefinition structure and APIPrefs_FloorPlanCutPlaneDef preferences type ID.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetPreferencesID
API_ElemViewDepthLimitationsID
API Types