API_​FontType

Font attribute representation.

    typedef struct {
        API_Attr_Head     head;
        Int32             charCode;
        short             ascent;
        short             descent;
        short             widMax;
        short             externalLeading;
        short             substituteInd;
        short             filler_1;
    } API_FontType;

 

Members

head
Specifies the name and index of the font. The flags field in the header specifies whether this is a vectorial font.
charCode
GSCharCode type character code used in the unicode-ANSI string conversion routines of the GSRoot String Manager.
ascent
The ascent of the characters (the height above the baseline).
descent
The descent of the characters (the depth below the baseline).
widMax
The maximum width of the characters in this font.
externalLeading
The value of the external leading.
substituteInd 10
Attribute ndex of the substitute font.

 

Remarks

You can not delete or modify fonts.

There is no additional data assigned to font attributes in the API_AttributeDef structure.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API_Attr_Head, API_Attribute,
Attribute Manager, API Types