API_​GDLModelViewOptions

Represents the GDL related model view options.

    typedef struct {
        GS::uchar_t        name[API_UniLongNameLen];
        API_Guid           guid;
        API_AddParType     **params;
        char               checkSum[64];
        API_Guid           supersetGuid;
        Int32              filler[4];
    } API_GDLModelViewOptions;

 

Members

name
Name of the option.
guid
Id of the option.
params
Additional parameters.
checkSum 14
MD5 checksum of params (output only).
supersetGuid 15
Id of another GDL related model view option which has all of the functionality of this one. If that is present, the current one is filled, but not shown in the Model View Options dialog.

 

Remarks

These settings correspond to the relevant items in the Document/Set Model View/Model View Options dialog.

Model view options are also part of the navigator view definition.

Call the ACAPI_Environment function with the APIEnv_GetViewOptionsID or APIEnv_ChangeViewOptionsID function codes to operate on this data.

Do not forget to dispose the params handle when it is not needed any more. Refer to the ACAPI_DisposeAddParHdl to do that.

 

Requirements

Version: API 13 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetViewOptionsID, APIEnv_ChangeViewOptionsID,
API_NavigatorView,
API Types