Geo Location data of the project.
typedef struct { API_PlaceInfo placeInfo; API_Coord3D surveyPointPosition; API_GeoReferenceData geoReferenceData; } API_GeoLocation;
Members
- placeInfo
- Project Location settings.
- surveyPointPosition
- Position of the Survey Point in the project.
- geoReferenceData
- Coordinate Reference System and Map Conversion data.
Remarks
This structure holds the parameters of the Geo Location settings of the project, such as geographic location, survey point position, and reference map conversion parameters.
In Teamwork you can retrieve the guid of this lockable object by using the "GeoLocation"
identifier as the parameter of
the ACAPI_TeamworkControl_FindLockableObjectSet function.
Requirements
- Version: API 25 or later
- Header: APIdefs_Environment.h
See Also
API_PlaceInfo
API_Coord3D
API_GeoReferenceData
APIEnv_GetGeoLocationID
APIEnv_SetGeoLocationID
APIEnv_GetSurveyPointTransformationID
API Types