Coordinate Reference System and Map Conversion parameters of the Geo Location of the project.
typedef struct { GS::UniString name; GS::UniString description; GS::UniString geodeticDatum; GS::UniString verticalDatum; GS::UniString mapProjection; GS::UniString mapZone; double eastings; double northings; double orthogonalHeight; double xAxisAbscissa; double xAxisOrdinate; double scale; } API_GeoReferenceData;
Members
- name
- Name by which the coordinate reference system is identified.
- description
- Informal description of this coordinate reference system.
- geodeticDatum
- Name by which this datum is identified.
- verticalDatum
- Name by which the vertical datum is identified.
- mapProjection
- Name by which the map projection is identified.
- mapZone
- Name by which the map zone, relating to the MapProjection, is identified.
- eastings
- Location along the easting of the coordinate system of the target map coordinate reference system.
- northings
- Location along the northing of the coordinate system of the target map coordinate reference system.
- orthogonalHeight
- Orthogonal height relative to the vertical datum specified.
- xAxisAbscissa
- Value along the easting axis of the end point of a vector indicating the position of the local x axis of the engineering coordinate reference system.
- xAxisOrdinate
- Value along the northing axis of the end point of a vector indicating the position of the local x axis of the engineering coordinate reference system.
- scale
- Scale to be used, when the units of the CRS are not identical to the units of the engineering coordinate system.
Remarks
This structure is a member of API_GeoLocation. These Geo Referencing map parameters correspond to the IfcCoordinateReferenceSystem and IfcMapConversion entities of the IFC standard.
Requirements
- Version: API 25 or later
- Header: APIdefs_Environment.h
See Also
API_GeoLocation
APIEnv_GetGeoLocationID
APIEnv_SetGeoLocationID
API Types