Parameters of the get component type in 3D operation.
typedef struct { API_Guid guid; Int32 dbElemIdx; Int32 bodyIdx; ULong ipgon; API_Coord3D c3; API_Coord3D normal; } API_Get3DComponentType;
Members
- guid
- Guid of the pointed element, or
APINULLGuid
, if no element is pointed. - dbElemIdx
- Index of the pointed element.
- bodyIdx
- Index of the pointed body in the pointed element.
- ipgon
- Index of the pointed polygon in the pointed element.
- c3
- Model coordinate of the point.
- normal
- Normal vector of the pointed polygon.
Remarks
For the utilization of API_Get3DComponentType see the APIIo_GetPointID function.
Requirements
- Version: API 14 or later
- Header: APIdefs_Interface.h
See Also
APIIo_GetPointID, API_NeigFilter, API_CursorSet, API_Coord3D, API_Vector3D, API_Neig, API Types