Parameters of the arc input operation.
typedef struct { char prompt[256]; bool startCoordGiven; bool negArc; bool changeCursorSet; bool disableDefaultFeedback; Int32 filler_1; API_CursorSet cursorSet; API_Coord3D origo; API_Coord3D startCoord; API_Coord3D pos; API_Neig neig; } API_GetArcType;
Members
- prompt
- [in] Prompt string to be displayed in the control box during input
- startCoordGiven
- [in] Use the start coordinate specified in the
startCoord
field - negArc
- [out] Negative (clockwise) arc has been entered
- changeCursorSet
- [in] Use the
cursorSet
field for changing cursor forms - disableDefaultFeedback
- Disable the default feedback drawing.
- cursorSet
- [in] Cursor set for customized visual feedback
- origo
- [in] The center coordinate of the arc
- startCoord
- [in/out] The start coordinate of the arc
- pos
- [out] The end coordinate of the arc
- neig
- [out] The neig found at the end point
Remarks
For the utilization of API_GetArcType
see the APIIo_GetArcID function.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Interface.h
See Also
APIIo_GetArcID, API_CursorSet, API_Coord3D, API_Neig, API Types