API_​GetLineType

Parameters of the line input operation.

    typedef struct {
        char               prompt[256];
        bool               changeFilter;
        bool               changeCursorSet;
        bool               changePlane;
        bool               disableDefaultFeedback;
        Int32              filler_1;
        API_NeigFilter     filter;
        API_CursorSet      cursorSet;
        API_Vector3D       planeNormal;
        API_Coord3D        startCoord;
        API_Coord3D        pos;
        API_Neig           neig;
    } API_GetLineType;

 

Members

prompt
[in] Prompt string to be displayed in the control box during input
changeFilter
[in] Use the filter field for filtering neigs during input
changeCursorSet
[in] Use the cursorSet field for changing cursor forms
changePlane
[in] Use the startCoord and planeNormal fields to define the input plane
disableDefaultFeedback
Disable the default line drawing feedback.
filter
[in] Neig filter for cursor snapping. See APIIo_InitNeigFilterID
cursorSet
[in] Cursor set for customized visual feedback
planeNormal
[in] The normal vector of the input plane
startCoord
[in] The start coordinate of the line
pos
[out] The end coordinate of the line
neig
[out] The neig found at the end point

 

Remarks

For the utilization of API_GetLineType see the APIIo_GetLineID function.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Interface.h

 

See Also

APIIo_GetLineID, API_NeigFilter, API_CursorSet, API_Vector3D, API_Coord3D, API_Neig, API Types