The possible parameter values of a non-array Library Part parameter.
typedef struct { char name [API_NameLen]; short index; bool locked; bool custom; Int32 nVals; GS::uchar_t **uStrValues; API_VLNumType **realValues; Int32 filler_1[4]; } API_GetParamValuesType;
Members
- name
- [in] the name of the parameter (optional)
- index
- [in] the index of the parameter (
0
:A
,1
:B
,2..n
: other parameters); (optional ifname
is given) - locked
- [out] the parameter is locked; i.e. the user cannot modify it
- custom
- [out] the parameter may have custom values (its
VALUES
command contains theCUSTOM
keyword) - nVals
- [out] the number of values
- uStrValues
- [out] the list of possible string values (Unicode strings in UTF-8 encoding)
- realValues
- [out] the list of possible numeric values
Remarks
The possible parameter values for the given parameter (defined by its name or index) are returned in this structure by the APIAny_GetParamValuesID function. For more information, see the description of the VALUES
command in the Parameter Script section of the GDL Reference Manual.
Do not forget to dispose the strValues
or the realValues
handles when they are not needed any more.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Goodies.h