API_​GetPolyType

Parameters of the polygon input operation.

    typedef struct {
        char                  prompt[256];
        bool                  changeCursorSet;
        bool                  changePlane;
        bool                  disableDefaultFeedback;
        bool                  getZCoords;
        API_PolyGetMethod     method;
        API_CursorSet         cursorSet;
        API_Vector3D          planeNormal;
        API_Coord3D           startCoord;
        API_Coord             **coords;
        API_PolyArc           **parcs;
        Int32                 nCoords;
        Int32                 nArcs;
        API_Neig              neig;
        double                **zCoords;
        Int32                 filler_1;
        bool                  polylineWas;
        bool                  useStandardPetPalette;
        bool                  filler_2[2];
        Int32                 filler_3;
    } API_GetPolyType;

 

Members

prompt
[in] Prompt string to be displayed in the control box during input
changeCursorSet
[in] Use the cursorSet field for changing cursor forms
changePlane
[in] Use the startCoord and planeNormal fields for defining the input plane
disableDefaultFeedback
[in] Disable the default polygon drawing feedback
getZCoords 6.1
[in] Retrieve z coordinates in case of 3D input
method
[in] The polygon input method

API_PolyGetMethod

Meaning

APIPolyGetMethod_General

Gets an arbitrary closed polygon

APIPolyGetMethod_Rect

Gets a rectangle

APIPolyGetMethod_RotRect

Gets a base vector then a rectangle perpendicular to it

APIPolyGetMethod_Polyline

Gets a polyline (can be open)

cursorSet
[in] Cursor set for customized visual feedback
planeNormal
[in] The normal vector of the input plane
startCoord
[in] The start coordinate of the polygon
coords
[out] The polygon coordinates, indexed from 1 to nCoords. The first coordinate is the same as the last one
parcs
[out] The polygon arcs segments, indexed from 1 to nArcs
nCoords
[out] The number of the polygon coordinates
nArcs
[out] The number of curves in the polygon
neig
[out] The closing neig of the polygon
zCoords 6.1
[out] Handle containing the z coordinates of the correspondong polygon nodes (retrieved only on demand by passing true in getZCoords)
polylineWas
[out] Polyline contour has been entered
useStandardPetPalette
[out] Use standard polygon input palette

 

Remarks

For the utilization of API_GetPolyType see the APIIo_GetPolyID function.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Interface.h

 

See Also

APIIo_GetPolyID
API_CursorSet
API_Vector3D
API_Coord3D
API_Coord
API Types