Describes a tracing (ghost) database.
typedef struct { API_Coord offset; double rotation; double scale; GSTime time; Int32 filler_1; API_DatabaseUnId parentDatabase; API_DatabaseUnId ghostDatabase; API_DatabaseTypeID ghostDBType; API_ShowGhostType ghostType; API_ElemFilter filter; bool filler_2[5]; short floor; short filler_3; bool activated; bool show; short filler_4; API_RGBAColor ghostColor; bool ghostOriginalColor; bool ghostOriginalTone; bool ghostBackgroundFill; bool filler_5[5]; API_RGBAColor viewColor; bool viewOriginalColor; bool viewOriginalTone; bool viewBackgroundFill; bool filler_6; bool ghostOnTop; bool filler_7[3]; } API_GhostRecord;
Members
- offset
- Position of the reference database.
- rotation
- Rotation angle of the reference database.
- scale
- Scale factor of the reference database.
- time
- Last modification time of the reference database.
- color
- Reference database color with transparency.
- parentDatabase
- Identifier of the parent database (i.e. out of which the reference database was created from).
- ghostDatabase
- Own identifier.
- ghostDBType
- Type of the reference database.
- ghostType
- Reference previous/above current/below current story.
- filter
- Tells which element types are visible.
- floor
- Original floor of the reference database.
- activated
- Is it activated?
- show
- Is it shown?
- ghostColor
- Reference database color with transparency.
- ghostOriginalColor
- The color of the ghost view.
- ghostOriginalTone
- The tone of the ghost view.
- ghostBackgroundFill
- The background fill of the ghost view.
- viewColor
- Parent database color with transparency.
- viewOriginalColor
- The color of the originating view.
- viewOriginalTone
- The tone of the originating view.
- viewBackgroundFill
- The background fill of the originating view.
- ghostOnTop
- Is Ghost on the top?
Remarks
This structure describes the Trace feature related information.
Requirements
- Version: API 11 or later
- Header: APIdefs_Environment.h
See Also
API_Coord, API_RGBAColor, API_DatabaseUnId,
API Types
APIEnv_CreateGhostRecordID, APIEnv_GetGhostRecordID, APIEnv_DeleteGhostRecordID