API_​GhostStoryType

Ghost Story settings.

    typedef struct {
        bool               on;
        bool               showOne;
        bool               showAbove;
        bool               showBelow;
        short              storyInd;
        short              filler_1;
        API_RGBColor       ghostColor;
        API_ElemFilter     filter;
        Int32              filler_2;
    } API_GhostStoryType;

 

Members

on
Ghost story is visible or hidden
showOne
Ghost story is specified in the storyInd field
showAbove
Show the story above the current as ghost story
showBelow
Show the story below the current as ghost story
storyInd
The index of the story displayed as ghost story (if showOne is true)
ghostColor
Ghost story color
filter
Element type filter to enable/disable elements to show on the ghost story

 

Remarks

This structure is a member of API_StoryInfo.

Featuring API 10  Ghost story settings can be retrieved by the APIEnv_GetGhostStorySettingsID environment function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_RGBColor
API_ElemFilter
API_StoryInfo
APIEnv_GetGhostStorySettingsID
API Types