API_​GISAngleRef

GIS angle reference.

    typedef struct {
        double             angleVB;
        API_GISAngular     angleGIS;
    } API_GISAngleRef;

 

Members

angleVB
Angle in the Virtual Building, in radian, a direction on the floorplan
angleGIS
Angle in GIS, in GIS measurement unit

 

Remarks

It describes an angle in the floorplan in radian and in the given GIS angle measurement unit.

For GIS measurement units refer to the API_GISCoordinateSystem structure.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

GIS Reference
API_GISRef
API_GISAngular
API_GISCoordinateSystem
APIDb_GetGISRefID
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
API Types