API_​GISAngular

Describes an angle in GIS.

    typedef struct {
        double     angleDouble;
        short      angleDeg;
        short      angleMin;
        short      angleSec;
        char       hemiLetter;
        char       filler_1;
    } API_GISAngular;

 

Members

angleDouble
Double precision angle, used for not whole values
angleDeg
Degree (if it is a whole number)
angleMin
Minutes (if it is a whole number)
angleSec
Seconds (if it is a whole number)
hemiLetter
Hemisphere abbreviation letter, can be : ‘N’ ‘S’ ‘E’ and ‘W’

 

Remarks

It holds the angle as you have put it, the stored values will not be changed nor converted. All the members are not used in every case, the coordinate system’s angleUnit field shows which members will be used (see also: GISAngularUnit).

This structure is used in API_GISAngularPos, API_GISAngleRef and API_GISMapProjectionParam.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

GIS Reference
API_GISAngularPos
API_GISAngleRef
API_GISRef
API_GISMapProjectionParam
APIDb_GetGISRefID
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
API Types