API_​GISCoordinateSystem

Describes a geographical or projected map coordinate system.

    typedef struct {
        GISCoordinateSystemType       type;
        API_GISEPSGData               mainCRS;
        API_GISEPSGData               datum;
        API_GISEPSGData               primeMeridian;
        API_GISEPSGData               ellipsoid;
        API_GISEPSGData               sourceCRS;
        API_GISEPSGData               projection;
        API_GISEPSGData               coordOpM;
        API_GISMapProjectionParam     **mapProjParams;
        GISLinearUnit                 uvUnit;
        GISLinearUnit                 hUnit;
        GISAngularUnit                 angleUnit;
        Int32                         filler_1;
    } API_GISCoordinateSystem;

 

Members

type
CST_Unknown, CST_Geographic (longitude and latitude) or CST_Projected (map projections using linear units)
mainCRS
Coordinate Reference System (CRS), it can be geographical or projected
datum
Datum of CRS
primeMeridian
Prime Meridian of CRS
ellipsoid
Ellipsoid of CRS
sourceCRS
Source geographical CRS, if type is projected
projection
Map projection, if type is projected
coordOpM
Coordinate operation method
mapProjParams
Handle of the variable numbered projection parameters
uvUnit
Units of valus in map plane
hUnit
Height unit
angleUnit
Angle unit

 

Remarks

This structure can describe two types of coordinate systems: geographical and projected. Geographical coordinate systems are spherical coordinate system a position is described by two angles: longitude and latitude. These angles are measured from the Equator and the Prime Meridian of the Earth.
Projected coordinate systems are built up by a projection; Earth surface is projected to a map plan. A position is described by two linear distances from a datum on map plan.

This structure can describe all the coordinate systems that can be found at the home page of the European Petroleum Survey Group (http://www.epsg.org). It stores EPSG references of coordinate system parameters, and also has units and database type selectors enabling simple calculatons and conversions between geodetic parameters and SI units.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

GIS Reference
API_GISRef
API_GISEPSGData
API_GISMapProjectionParam
GISLinearUnit
GISAngularUnit
APIDb_GetGISRefID
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
API Types