API_​GISEPSGData

Describes an EPSG reference.

    typedef struct {
        char      name[GISNameLen];
        Int32     code;
        Int32     filler_1;
    } API_GISEPSGData;

 

Members

name
EPSG name of the referenced data (see www.epsg.org)
code
EPSG code of the referenced data

 

Remarks

This structure is a member of API_GISCoordinateSystem and API_GISMapProjectionParam.

Note that the server application does not check name and code integrity, it only stores them. The length of the name should not be longer than 80 characters (by definition of EPSG).

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

GIS Reference
API_GISCoordinateSystem
API_GISMapProjectionParam
APIDb_GetGISRefID
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
API Types