API_​GISMapProjectionParam

Describes a map projection parameter.

     typedef struct {
         API_GISEPSGData     epsg;
         bool                valueIsAngular;
         char                filler_1[7];
         union {
             double          linear;
             API_GISAngular  angular;
         } value;
     } API_GISMapProjectionParam;

 

Members

epsg
EPSG reference of the parameter
valueIsAngular
Specifies whether the type of the parameter is angular or linear
linear
Linear value of the projection parameter; valid only if valueIsAngular is false
angular
Angular value of the projection parameter; valid only if valueIsAngular is true

 

Remarks

This structure holds the parameters of the GIS coordinate system (API_GISCoordinateSystem).

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

GIS Reference
API_GISCoordinateSystem
APIDb_GetGISRefID
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
API Types