Describes a position in Virtual Building and in GIS.
typedef struct { API_Coord3D positionVB; double heightGIS; union { API_GISLinearPos linear; API_GISAngularPos angular; } positionGIS; } API_GISPositionRef;
Members
- positionVB
- Position in the Virtual Building
- heightGIS
- Height in GIS
- linear
- Linear position in GIS, used if coordinate system is projected
- angular
- Angular position in GIS, used if coordinate system is geographical
Remarks
This structure is a member of API_GISRef.
Requirements
- Version: API 6.1 or later
- Header: APIdefs_Database.h
See Also
GIS Reference
API_GISRef
API_GISLinearPos
API_GISAngularPos
API_Coord3D
APIDb_GetGISRefID
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
API Types