API_​GISRef

Describes the GIS or survey reference of the plan.

    typedef struct {
        API_GISCoordinateSystem     coordinateSystem;
        API_GISPositionRef          firstRef;
        bool                        secondTypeIsAngle;
        char                        filler_1[7];
        union {
            API_GISPositionRef      point;
            API_GISAngleRef         angle;
        } secondRef;
    } API_GISRef;

 

Members

coordinateSystem
The Coordinate Reference System.
firstRef
First GIS reference. It is a position in the plan and a position in GIS world.
secondTypeIsAngle
Second reference type is an angle (true) or a position (false).
point
The second GIS reference, if it is a point.
angle
The second GIS reference, if it is an angle.

 

Remarks

The plan GIS reference is built in from two position reference and one position reference and one angle. Where the position reference is a position in plan space and a position in a map. Each position has height information as well. The angle reference is an angle in plan space and an angle in map. The GIS reference also have a GIS coordinate reference system description, with name, EPSG code, measurement units, projections and other parameters. Archicad saves this data to pln file, without convert them to SI units. You can set and get the current building GIS reference, and you also can convert values to SI.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Database.h

 

See Also

GIS Reference
API_GISCoordinateSystem
API_GISPositionRef
API_GISAngleRef
APIDb_GetGISRefID
APIDb_SetGISRefID
APIDb_ConvertToSIUnitsID
API Types