API_​GridEdgeInfo

Contains extended information of a API_GridMeshEdge.

    typedef struct {
        API_GridElemID     id;
        bool               mainAxis;
        bool               filler_1[7];
    } API_GridEdgeInfo;

 

Members

id
The identifier of the edge, the info belongs to
mainAxis
Whether it belongs to the main axis or not.

Remarks

The main axis is vertical. For more information see API_GridMesh.

Requirements

Version: API 12 or later
Header: APIdefs_Base.h

 

See Also

API_GridMeshDirection, API_GridMeshHead, API_GridMeshVertex, API_GridMeshEdge
API_GridMeshLine, API_GridMeshPolygon, API_GridMesh
API_Interval, API_Plane3D, API_Surface3D
API Types