API_​GridMeshEdge

Describes a Grid Mesh edge.

    typedef struct {
        API_GridMeshHead     head;
        API_GridElemID       begID;
        API_GridElemID       endID;
        UInt32               userData;
        UInt32               filler_1[3];
    } API_GridMeshEdge;

 

Members

head
General header for Grid Mesh.
begID
The identifier of the begin vertex.
endID
The identifier of the end vertex.
userData
Attached custom data.

Remarks

For more information see API_GridMesh.

Requirements

Version: API 12.0 or later
Header: APIdefs_Base.h

 

See Also

API_GridMeshDirection, API_GridMeshHead, API_GridMeshVertex, API_GridEdgeInfo
API_GridMeshLine, API_GridMeshPolygon, API_GridMesh
API_Interval, API_Plane3D, API_Surface3D
API Types