API_​GridMeshLine

Describes a grid line of the mesh.

    typedef struct {
        API_GridMeshHead     head;
        API_GridElemID       begID;
        API_GridElemID       endID;
        UInt32               userData;
        bool                 mainDir;
        bool                 filler_1;
        UInt32               filler_2[3];
    } API_GridMeshLine;

 

Members

head
Identifies the mesh element.
begID
The identifier of begpoint vertices.
endID
The identifier of endpoint vertices.
userData
Custom value assigned to this mesh line.
mainDir
If false then secondary direction.

Requirements

Version: API 12.0 or later
Header: APIdefs_Base.h

 

See Also

API_GridMeshDirection, API_GridMeshHead, API_GridMeshVertex, API_GridMeshEdge, API_GridEdgeInfo
API_GridMeshPolygon, API_GridMesh
API_Interval, API_Plane3D, API_Surface3D
API Types