A 3D mesh polygon with four edge indices
typedef struct { API_GridMeshHead head; GS::Array<API_GridElemID> neighbourIDs[API_GridMeshDirNum]; API_GridEdgeInfo edges[4]; Int32 filler_1[2]; } API_GridMeshPolygon;
Members
- head
- General Grid Mesh header.
- neighbourIDs
- The identifiers of the neighbour polygons in all the 8 (=API_GridMeshDirNum) directions).
- edges
- Edge indices of the grid mesh polygon.
Remarks
For more information see API_GridMesh.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Base.h
See Also
API_GridMeshDirection, API_GridMeshHead, API_GridMeshVertex, API_GridMeshEdge, API_GridEdgeInfo
API_GridMeshLine, API_GridMesh
API_Interval, API_Plane3D, API_Surface3D
API Types