Describes a Grid Mesh vertex.
typedef struct { API_GridMeshHead head; API_Coord surfaceParam; API_Coord3D coord; UInt32 filler_1[2]; } API_GridMeshVertex;
Members
- head
- General header for Grid Mesh.
- surfaceParam
- 2D coordinate of the vertex in the Grid Mesh’s local coordinate system.
- coord
- 3D coordinate of the vertex in the global coordinate system (relative to the owner story’s height).
Remarks
For more information see API_GridMesh.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Base.h
See Also
API_GridMeshDirection, API_GridMeshHead, API_GridMeshEdge, API_GridEdgeInfo
API_GridMeshLine, API_GridMeshPolygon, API_GridMesh
API_Interval, API_Plane3D, API_Surface3D
API Types