The grid parameters.
typedef struct { double spaceMainX; double spaceMainY; short nLineMainX; short nLineMainY; short filler_0; bool filler_1; bool gridSwitch; double spaceAuxX; double spaceAuxY; short nLineAuxX; short nLineAuxY; short filler_2; bool filler_3; unsigned char gridMode; double snapOffsX; double snapOffsY; double snapStepX; double snapStepY; short status; short filler_4; Int32 filler_5; double gridAngle; double gridOffsX; double gridOffsY; double gridOffsZ; API_RGBAColor backColor; API_RGBAColor gridColor; } API_GridType;
Members
- spaceMainX, spaceMainY
- horizontal / vertical spacing of the main grid
- nLineMainX, nLineMainY
- horizontal / vertical number of lines of the main grid
- gridSwitch
- true if grid is visible
- spaceAuxX, spaceAuxY
- horizontal / vertical spacing of the auxiliary grid
- nLineAuxX, nLineAuxY
- horizontal / vertical number of lines of the auxiliary grid
- gridMode
- Gravity to the grid; 0:none, 1:grid, 2:snap
- snapOffsX, snapOffsY
- horizontal / vertical offset of the snap grid
- snapStepX, snapStepY
- horizontal / vertical spacing of the snap grid
- status
- status of the grid
- gridAngle
- rotation angle of the grid, relative to horizontal
- gridOffsX, gridOffsY, gridOffsZ
- (x,y,z) offset of the grid
- backColor
- background color. Transparency is effective only in the Model window.
- gridColor
- color of main grid lines. Transparency is effective only in the Model window.
Remarks
Each database window may have different grid setting parameters.
To get the actual settings associated to a database use the APIDb_GetGridSettingsID function; to change the parameters refer to the APIDb_ChangeGridSettingsID function.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Database.h
See Also
APIDb_GetGridSettingsID, APIDb_ChangeGridSettingsID, API_RGBColor, API Types