Determines the behaviour of the hatch.
typedef enum { APIHatch_HasBkgRGBColor = 0x01, APIHatch_HasFgRGBColor = 0x02, APIHatch_OverrideFgPen = 0x04, APIHatch_OverrideBkgPen = 0x08, APIHatch_OverrideFillInd = 0x10 } API_HatchFlags;
Members
- APIHatch_HasBkgRGBColor
- The hatch background color is defined by an RGB Color.
- APIHatch_HasFgRGBColor
- The hatch foreground color is defined by an RGB Color.
- APIHatch_OverrideFgPen
- In case of a building material type hatch, use the fill pen in the hatch, instead of the building material’s fill pen.
- APIHatch_OverrideBkgPen
- In case of a building material type hatch, use the fill background pen in the hatch, instead of the building material’s fill background pen.
- APIHatch_OverrideFillInd
- In case of a building material type hatch, use the fill in the hatch, instead of the building material’s fill.
Requirements
- Version: API 17 or later
- Header: APIdefs_Elements.h