API_​HatchOrientation

Fill orientation and distortion parameters.

    typedef struct {
        API_HatchOrientationTypeID     type;
        unsigned short                 version;
        short                          filler_1;
        Int32                          flags;
        Int32                          filler_2;
        API_Coord                      origo;
        double                         matrix00;
        double                         matrix10;
        double                         matrix01;
        double                         matrix11;
        double                         innerRadius;
    } API_HatchOrientation;

 

Members

type
Type of the cover fill orientation

API_HatchOrientationTypeID

Meaning

API_HatchGlobal

The fill is linked to Project Origin, the orientation of the hatching is always orthogonal independently of transformations made on the filled element

API_HatchRotated

The fill is linked to Fill Origin, a single handle shows the orientation of the fill, and the fill pattern starts at the origin of the filled element

API_HatchDistorted

The pattern of the fill is distorted in x and/or y directions

API_HatchCentered Featuring API 13

The pattern is circular fill distorted.

version Featuring API 13
Version of the HatchOrientation
flags Featuring API 13
Flags for HatchOrientation

APIHatchOrinFlag_XAxisGlobal

The fill origin’s X coordinate is the global origin’s X coordinate

APIHatchOrinFlag_YAxisGlobal

The fill origin’s Y coordinate is the global origin’s Y coordinate

APIHatchOrinFlag_UseInnerRadius

Radius for circular fill distortion; the origin of the base circle will be placed on the Y fill axis in the (0, -innerRadius) position

APIHatchOrinFlag_GlobalOrientation

Use local orientation, or use the distortion matrix, when it is not set.

APIHatchOrinFlag_FitX

Reset the pattern’s X size to the defined X vector’s length (effective for symbol fills only)

APIHatchOrinFlag_FitY

Reset the pattern’s Y size to the defined Y vector’s length (effective for symbol fills only)

APIHatchOrinFlag_KeepProportion

Keep proportion of symbol fill pattern (effective for symbol fills only)

origo
The origo of the fill relative to the project origin
matrix00
The x component of the primary distortion (direction) vector (the cosine of the fill angle, if not distorted)
matrix10
The y component of the primary distortion (direction) vector (the sine of the fill angle, if not distorted)
matrix01
The x component of the secondary distortion vector (the cosine of the angle of the normal vector, if not distorted)
matrix11
The y component of the secondary distortion vector (the sine of the angle of the normal vector, if not distorted)
innerRadius 13
Radius for circular fill distortion.

 

Remarks

This structure holds the orientation and distortion parameters of the cover fills of API_ShellBaseType, API_SlabType and API_HatchType elements.

 

Requirements

Version: API 10 or later
Header: APIdefs_Elements.h

 

See Also

API_ShellBaseType, API_SlabType, API_HatchType
API_Coord, API Types