API_​HatchQuantity

Describes the different calculated values for fills.

    typedef struct {
        double     surface;
        double     perimeter;
        double     holesPrm;
        double     holesSurf;
        double     filler_1[8];
    } API_HatchQuantity;

 

Members

surface
area of the fill
perimeter
perimeter of the fill
holesPrm
perimeter of holes in the fill
holesSurf
area of holes in the fill

 

Remarks

See also the fill parameters for listing in Appendix A of the GDL Reference manual.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types