Describes the dimensions of a window/door.
This structure is obsolete. Use Window/Door Dimension Markers instead.
typedef struct { bool dimOn; bool sameSide; bool isCustom; bool showMarker; bool showWH; bool showSH; bool dispNH; bool filler_1; char idStr[4]; short pen; short filler_2; double headDist; double footLen; double textDist; double paraDist; double headSize; double ppCorr; char ppStr[8]; Int32 filler_4[6]; API_NoteType note1; API_NoteType note2; API_NoteType note3; API_NoteType note4; Int32 filler_5[8]; } API_HoleDim;
Members
- dimOn
- True if the window/door has dimensions.
- sameSide
- Position on wall’s left or right side.
- isCustom
- The dimensions marker is defined in GDL.
- showMarker
- Show marker?
- showWH
- Show width/height?
- showSH
- Show parapet height?
- dispNH
- Display nominal height?
- idStr[4]
- Identifier string.
- pen
- The pen index of the dimension.
- headDist
- The length of the centerline’s extension out to the marker circle (in mm).
- footLen
- The length of the centerline’s extension on the side opposite the marker (in mm).
- textDist
- The distance of the Width/Height Dimension Text’s right justification point from the wall (in mm).
- paraDist
- The distance of the Sill/Threshold Height Dimension Text baseline from the wall (in mm).
- headSize
- The length of the Centerline’s extension out to the Marker circle (in mm).
- ppCorr
- Parapet correction (subfloor thickness).
- ppStr[8]
- Parapet prefix string.
- note1
- Index note.
- note2
- Width note.
- note3
- Height note.
- note4
- Sill note.
Requirements
- Version: API 2.1 to 3.2
- Header: APIdefs_Elements.h
See Also
API_NoteType, API_WindowType, API_DoorType, API Types