Describes a hotlink node.
typedef struct { API_Guid guid; API_HotlinkTypeID type; API_HotlinkStoryRangeID storyRangeType; GSTime updateTime; IO::Location *sourceLocation; GS::uchar_t name [API_UniLongNameLen]; GS::uchar_t refFloorName [API_UniLongNameLen]; short refFloorInd; bool filler_3; bool filler_1; GSType ownerId; API_HotlinkUserData userData; Int32 filler_2[4]; IO::Location *serverSourceLocation;API_HotlinkSourceTypeID sourceType; UInt64 fileSize; Int64 versionNumber; } API_HotlinkNode;
Members
- guid
- Globally unique Id of the node
- type
- Hotlink source reference type (Hotlinked Module or XRef)
- storyRangeType
- Single or multistory hotlink
- updateTime
- Time of last updated
- sourceLocation
- Location of the source file
- name
- Display name of the hotlink node
- refFloorName
- Name of the hotlinked story in case of single story hotlinked module
- refFloorInd
- Index of the hotlinked story in case of single story hotlinked module
- ownerId
- Owner identifier of the hotlink node (0 means the Hotlink Manager of Archicad)
- userData
- Optional custom data handled by the owner
- serverSourceLocation
- Location of the source file on the server
- sourceType
- Source reference type, could be either APIHotlink_SingleStory, or APIHotlink_AllStories
- fileSize
- Size of the source file.
- versionNumber
- File revision number (only for revisions).
Remarks
The destructor of this structure will automatically deallocate the memory pointed by the sourceLocation
, serverSourceLocation
and userData
fields. Make sure those point to memory on heap.
Requirements
- Version: API 12 or later (for
serverSourceLocation
member: API 24 or later) - Header: APIdefs_Database.h
See Also
API_HotlinkTypeID
API_HotlinkStoryRangeID
API_HotlinkUserData
API_HotlinkType
APIDb_GetHotlinkNodeID
APIDb_CreateHotlinkNodeID
APIDb_GetHotlinkInstancesID
API Types