API_​HotlinkType

Represents a Hotlink Module type or XRef type hotlink instance element.

    typedef struct {
        API_Elem_Head         head;
        API_HotlinkTypeID     type;
        Int32                 filler_1;
        API_Guid              hotlinkNodeGuid;
        API_Guid              hotlinkGroupGuid;
        API_Tranmat           transformation;
        short                 floorDifference;
        bool                  suspendFixAngle;
        bool                  skipNested;
        bool                  ignoreTopFloorLinks;
        bool                  relinkWallOpenings;
        bool                  adjustLevelDiffs;
        char                  filler_2[2];
        char                  filler_3[16];
        Int32                 filler_4[2];
    } API_HotlinkType;

 

Members

head
General element header.
type
Type of the hotlink.
filler_1
Reserved for further use.
hotlinkNodeGuid
Reference to the associated hotlink node (see API_HotlinkNode).
hotlinkGroupGuid
Reference to the associated element group.
transformation
Placement transformation of the hotlink instance.
floorDifference
Floor difference in case of hotlink module.
suspendFixAngle
Adjust angle of fixed-angle elements to reflect module rotation.
skipNested
Skip nested hotlinks.
ignoreTopFloorLinks Changed in API 19
Top linked building elements will not keep their top floor links (homeFloorLinksOnly before 19).
relinkWallOpenings Changed in API 19
Wall openings linked to stories will be relinked to walls to follow their elevation if the story structures differ.
adjustLevelDiffs Changed in API 21
If this parameter is true, then all Hotlink elements will retain their original vertical position relative to the Hotlink insertion point. Otherwise elevation of elements will follow the shift in Story Levels in the Host Project. Therefore, Hotlink element may shift vertically.

 

Requirements

Version: API 12 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head
API_Element
Element Manager
APIDb_GetHotlinkInstancesID
APIDb_GetHotlinkNodeID
APIDb_GetCompoundInfoStringID
API_HotlinkNode
API Types