API_​HotspotType

Represents a hotspot.

    typedef struct {
        API_Elem_Head     head;
        short             pen;
        short             filler_1[3];
        API_Coord         pos;
        double            height;
        Int32             filler_2[2];
    } API_HotspotType;

 

Members

head
General element header.
pen
Pen attribute index.
pos
2D position of the hotspot.
height
Z coordinate of the hotpsot (this can come from a GDL script).

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_Coord, API_Element,
Element Manager, API Types